Search found 4 matches

by Specvay
Sat Mar 23, 2019 8:11 am
Forum: Platinum Pro Plug-in
Topic: S14 rb neo not retaining timing, news help
Replies: 0
Views: 118

S14 rb neo not retaining timing, news help

So I drop my car off to get tune. They had the same issue. Set trigger angle and it start but only run for 10sec, cut off. When u turn off the car, the timing is completely off again and u have to set trigger angle again. They told me I need to get a aftermarket trigger cam, since it doing that. I t...
by Specvay
Sun Feb 10, 2019 9:22 pm
Forum: Platinum Pro Plug-in
Topic: S14 rb neo not starting
Replies: 5
Views: 345

Re: S14 rb neo not starting

Thanks again Matt for the help! I'm having a issue where I set trigger angle constantly after a few start up. afterwards it start up and does a few time, it just crank. Grabbing a timing light I realize the trigger angle completely off again. If I reset trigger angle again it the same situation agai...
by Specvay
Fri Feb 08, 2019 7:34 am
Forum: Platinum Pro Plug-in
Topic: S14 rb neo not starting
Replies: 5
Views: 345

Re: S14 rb neo not starting

using a timing light. i set crank to 0 and the trigger to 40 on compression and the car run then dies, which is a good sign, it got me really excited. later i went back to try to crank and it did the samething as before ( just crank). so i took my timing cover again and set ignition to 0 degree and ...
by Specvay
Wed Feb 06, 2019 10:22 pm
Forum: Platinum Pro Plug-in
Topic: S14 rb neo not starting
Replies: 5
Views: 345

S14 rb neo not starting

I got a s14 swapped a neo with1050id inject with 6266 turbo. I loaded the base map and it not starting. It cranks and sound like it want to start. I'm assuming I have to set ignition timing correct? Lock timing and disable injector, timing light and adjust cas.... Do I have to put any number in trig...

Go to advanced search