WARNING on Mazda FS-DE ignition settings

Maxx Mazda

WARNING on Mazda FS-DE ignition settings

Postby Maxx Mazda » Wed Aug 29, 2007 9:53 am

Just a warning to all, make sure your spark edge is set to FALLING in the ignition setup page, or you will fry your coils. I have fried 3 sets so far, and was finally able to narrow it down to that setting. Constant charge type, 5ms dwell time, and felling edge and you'll be happy.

matt510

thanks

Postby matt510 » Thu Aug 30, 2007 4:02 am

Thanks for that piece of warning - in fact 99% of ignition systems require the spark edge to be set to falling. The biggest exception to this rule is SOME honda ignition systems - go figure !

Maxx Mazda

Okay

Postby Maxx Mazda » Thu Aug 30, 2007 3:06 pm

Which begs the question, why? I the falling edge of what will trigger the coil to fire? The trigger tooth? Cause that setting is in the trigger setup page.

So why would changing the edge to falling fry the coils?

matt510

begs the question

Postby matt510 » Fri Aug 31, 2007 2:47 am

No question is begged if you understood what you were doing when you change the spark edge in the software! Its really quite simply however if you dont understand how your ignition system works you wont get it.

Anyways changing the spark edge inverts the output signal from the ECU, spark edge falling and the signal going to the ignitor sits at ground normally, rises to +12V to charge the coil then back to ground to fire the spark (hence spark edge is falling). Change the spark edge to rising and the signal coming out of the computer is +12V the whole time, pulls to ground to charge the coil and then back up to +12V to fire the spark (hence spark edge is rising).

So you can see it makes perfect sense, the big question is why do some OEMs use an NPN transistor for the ignition module and why do others us a PNP !!!

crispeed

why?

Postby crispeed » Fri Aug 31, 2007 9:55 pm

Probably the same reason why most of the early Honda motors spun anti-clockwise!

drjekl

Re: why?

Postby drjekl » Mon Sep 10, 2007 6:12 pm

indeed.....why?.... even the owners are backwards


Return to “Technical Support (from EZboard)”

Who is online

Users browsing this forum: No registered users and 4 guests