Ignition signal on 3RZ (2.7l) hilux engine

smaddock
Posts: 5
Joined: Fri Dec 26, 2008 4:58 pm

Ignition signal on 3RZ (2.7l) hilux engine

Postby smaddock » Thu Jan 08, 2009 6:17 pm

Hi,

I've recently purchased an Interceptor, and have hooked it up to my 2.7l hilux engine. The only problem is once the interceptors in, the idle doesn't drop below 1200rpm, but as soon as I disconnect it, it drops back to 800rpm.

The way its hooked up currently is the +ve signal from the crank sensor goes to DIGIN1, DIGOUT1 REL+ goes to the ECU where the crank sensor +ve went, and the crank sensor -ve goes to signal earth on the interceptor. Do I need to do anything with the DIGOUT1 REL- ?

The only thing I can think of, from the wiring diagram it looks like the crank sensor and cam pos sensor both have their -ve going to the same pin on the ecu, and I've cut this and wired it to signal earth. Would I need to run another wire from the cam pos sensor -ve to the ecu?

This is confusing me quite a bit, so if anyone has any experience pls put me out of my misery :)

Thanks,

Simon

User avatar
Claudio
Posts: 1188
Joined: Wed Sep 26, 2007 10:44 am
Location: Santo Domingo, Dominican Republic
Contact:

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby Claudio » Sun Jan 11, 2009 2:01 pm

Is your engine distributed or coil on plug? also, is it drive by wire or cable throttle?

Ive worked with this application, but not the DBW version. Let me know.
Claudio
[email protected]
Independant Haltech Sales & Tech Support

smaddock
Posts: 5
Joined: Fri Dec 26, 2008 4:58 pm

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby smaddock » Sun Jan 11, 2009 6:24 pm

Its got 2 coil packs, which I'm assuming fire in a wasted spark arrangement. And its cable throttle.

User avatar
Claudio
Posts: 1188
Joined: Wed Sep 26, 2007 10:44 am
Location: Santo Domingo, Dominican Republic
Contact:

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby Claudio » Mon Jan 12, 2009 12:35 pm

Is it something like this? http://i188.photobucket.com/albums/z245 ... do_90_.jpg

Or one of these: http://www.tucarro.com.ar/toyota-TCMOD- ... gp-90b.jpg

If its the 2nd one i have a map you could try. Are you modifying it in anyway? or will it say NA with no mods? What will you do with it? Email me for that map.
Claudio
[email protected]
Independant Haltech Sales & Tech Support

smaddock
Posts: 5
Joined: Fri Dec 26, 2008 4:58 pm

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby smaddock » Mon Jan 12, 2009 7:08 pm

ClaudioRX7 wrote:Is it something like this? http://i188.photobucket.com/albums/z245 ... do_90_.jpg

Or one of these: http://www.tucarro.com.ar/toyota-TCMOD- ... gp-90b.jpg

If its the 2nd one i have a map you could try. Are you modifying it in anyway? or will it say NA with no mods? What will you do with it? Email me for that map.


Actually it's neither of these, the engine is from a RN169 Toyota Hilux in Australia, which is the same engine as used in the Toyota Prado's here as well.

Oh, btw, just tried sending you email but for some reason it keeps failing. I can send emails to any other address, but seems to fail with yours ???

HaltechAdam
Haltech Staff
Posts: 242
Joined: Mon Jul 07, 2008 12:24 pm

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby HaltechAdam » Fri Jan 16, 2009 8:46 am

Wiring diagrams sent to your email address.
Cheers

smaddock
Posts: 5
Joined: Fri Dec 26, 2008 4:58 pm

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby smaddock » Sat Jan 17, 2009 2:37 pm

Thanks for the emails mate, all hooked up and running. Just need to organise tune :)

grandtorino92
Posts: 2
Joined: Mon Apr 20, 2015 5:49 pm

Re: Ignition signal on 3RZ (2.7l) hilux engine

Postby grandtorino92 » Mon Apr 20, 2015 8:31 pm

Im also after info on how to wire a ps1000 up to the same engine.


Return to “Interceptor”

Who is online

Users browsing this forum: No registered users and 1 guest