E6K 6-cyl engine injector wiring

fdahl_009
Posts: 53
Joined: Fri Jan 09, 2009 7:16 am

E6K 6-cyl engine injector wiring

Postby fdahl_009 » Wed Sep 09, 2015 10:17 pm

Hi all!

Currently started to wire a E6K for a dyno test on a Alfa Romeo V6, an old Gr. A race engine.
The old engine management from the old days when this car was raced are fried, no one knows / remember if the engine do run at all, so they wanted it tested in an engine dyno to check everything and he wants to keep it a bit "oldschool", the reason for the E6K being used.

The setup is a 60-2, hall sensor, low impedance (3ohm) injectors, single coil and distributor.

One thing that I noticed when reading the manual is the following;
- On page 76 is a schematic showing the injector setup for a 6 cyl engine. Shwon as I expect it to be.
- but then, on the middle of page 114, it is listed differently - as far as I understand at the moment at least..

The firing order for this engine is 1-4-2-5-3-6. I would have done the following as per "all" the other ecus I have worked with;
INJ1 -> cyl 1&5
INJ2 -> cyl 4&3
INJ3 -> cyl 2&6

But the manual suggests this;
INJ1 -> 1&4
INJ2 -> 2&5
INJ3 -> 3&6


How should I wire this?

Fredrik,

fdahl_009
Posts: 53
Joined: Fri Jan 09, 2009 7:16 am

Re: E6K 6-cyl engine injector wiring

Postby fdahl_009 » Thu Sep 10, 2015 8:15 am

I have now started the wiring. A little more info / questions.

To start, I did not remember the manual right.
- On page 76, in the text above, high impedance injectors are mentioned, I guess maybe that is why the two pages are different
- This is how the wiring are listed in the manual on the "second page" (corrected for "my" firing order):
INJ1 / INJ 2 -> cyl 1 & 4
INJ3 / INJ4 -> cyl 2 & 5
DIGITAL OUT 2 -> cyl 3 & 6

So, now I have wired it as per above, with one injector to each channel except the digital out2 which takes both cyl 3 & 6. A bit weird having 5 channels used for 6 cyls, but I guess this is the way to go..

Setup as sequential in the software - and I then see the HOME signal sensor settings appears.
On newer ecus a home signal for semi-seq on 60-2 is not needed - so do the ecu really need a Home signal?

The main reason for asking is that we do not get any spark, but the ecu sees rpm while cranking. Not checked to see if the injectors are pulsing yet.
Pin 36 is connected to the "input +" of an dumb igniter, the way I usually do on these setups with a single coil and distributor.


Return to “Old Engine Management Systems”

Who is online

Users browsing this forum: No registered users and 3 guests