Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Tue May 05, 2015 3:29 pm

Hey,

I can't not run seq inj on this msm 04, only batch.

Any idea ?

Thanks

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Wed May 06, 2015 9:40 pm

Why not? I've done it in MSMs. No reason you shouldn't be able to.
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Wed May 06, 2015 9:46 pm

seq will fire only cylinder 4 and 3...

:\

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Thu May 07, 2015 2:08 am

Can you post your map? You're using an E8?
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Thu May 07, 2015 2:38 am

Haltech 1000, I use the official base map, I changed the injectors resistance from 1-3 to high, that is all

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Thu May 07, 2015 5:46 am

Are you using a patch loom? If so, we had big problems with them the last time we tried one in a MSM. We ended up building our own.
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Thu May 07, 2015 6:27 pm

We use the look that came with the haltech1000.

Problems you say ?

Well, when i connect the sp1000 to the cars look it does not get power, I had to supply it with other power source - this is one problem.
Second problem is the no seq inj, batch only problem.

Can you help me out ? Can you give me some info about the problems you have with the patch loom on MSM ?

Thanks !
Elior

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Thu May 07, 2015 6:34 pm

Did the loom look like this? Sounds like it is the patch loom and is most likely your issue. Contact me directly at the email below and we can sort something out. I would contact your dealer and/or Haltech also and tell them what you have and see what they can do for you. As I said, there were serious issues with the Harness about 18 months ago when we tried to use one. Sounds like you have the exact same deal going on.

Image
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Thu May 07, 2015 6:39 pm

Email sent

Thanks

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Sat May 09, 2015 1:51 am

I checked the car loom, injectors pins, continuity test.
injector 1 ok
injector 2 ok
Injectors 3+4 wired together

???
I don't think this is normal...

If understand correctly it runs on batch while 3 injectors fire every time....

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Sat May 09, 2015 10:57 pm

Your patch loom is not built correctly. There's no use trying to make it work when you have a part that's wrong. You should contact the dealer you purchased the loom from and request a refund and assistance. Haltech also needs to get this loom right. It's been a known issue for no less than a year. I sent documentation to Haltech USA over a year ago when I had the same trouble with a loom.
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Sun May 10, 2015 12:13 am

I am talking about the cars oem stock loom not Haltech patch loom - The mazda loom the connects to the stock ecu.

LMS_689
Posts: 1397
Joined: Thu Oct 18, 2007 6:30 am
Location: Floyds Knobs, IN USA
Contact:

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby LMS_689 » Mon May 11, 2015 6:33 pm

Not sure what you're measuring, but the OE wiring is for proper sequential.


Image
Haltech Parts and Accessories
Custom Harness Construction
http://www.lms-efi.com
chris@lms-efi.com
502-515-7482

elior77
Posts: 31
Joined: Mon Apr 06, 2015 6:17 am

Re: Haltech 1000 on Miata Mazdaspeed 2004 - only batch inj

Postby elior77 » Mon May 11, 2015 6:34 pm

I know this diagram, this is the reason i post this question...


Return to “Tuning Discussions”

Who is online

Users browsing this forum: No registered users and 2 guests