Trigger setting motronic 60-2 +1home volvo b5254s 5cyl

Questions about the Platinum Sport series ECU settings or features? Ask here.
MatthiasDpt
Posts: 1
Joined: Thu Jan 25, 2018 7:32 pm

Trigger setting motronic 60-2 +1home volvo b5254s 5cyl

Postby MatthiasDpt » Thu Jan 25, 2018 11:16 pm

Hi, I'm a student from belgium (car technology).

I'm in my final year and for my thesis I need to make a volvo b5254s engine (2435cc 5 cyl) run on a haltech platinum sport 2000.
the engine sit on a test bench and the original motronic ecu can still be used by changing 2 plugs.
The problem that I'm having is that I can't figure out how to set up my trigger :( .

Used a scoop to measure the cranksignal signal was fine same as the camshaft signal.
The crankshaft has 60 teeth with 2 teeth missing, hall sensor on camshaft.
I have checked the trigger angle in the volvo books that we have here in school it said trigger angle 90°.
Checked it by putting the ignition lock on 0° and then it fired at 90° so should be ok.

The problem I'm having is that the ignition doesn't fire every 2 turns it skips sometimes.
When using the ignition timig light I could clearly see this.
Because of this I can barely get the engine started and it run very bad when it starts.

Has any of you had a similar problem yet ? I have searched the forum yet but couldn't find that much on 5 cylinder engine's with trigger problems.

The Trigger settings I have now are
Motronic 60-2 +1 home
Trigger angle 90°
trigger edge rising
home edge rising (tried changing these but that didn't seem to help)
home pull up enabled ( tried disabled but didn't get a singal on the home counter so enabled it again)
not using filters
not checking the trigger -ve treid checking it on did not help and should be off I gues because both are wired to the ecu

I also tried setting the teeth offset to 58 and trigger angle to 102°.

When is us the trigger and home counter is get trigger 884 and home 7 after trying to start for a few seconds.
the miss counter always indicates zero.

Ignition dwell time is set on 4.7 ms measured this when the engine was running on the motronic ecu.
the engine runs fine when i connect it to the motronic ecu.

Does anyone have an idea where I have it wrong. Any help would be very much appreciated.

Thanks in advance,
A desperate student

User avatar
HoSDo_earth
Posts: 180
Joined: Fri Jan 08, 2010 10:39 pm
Location: Udine - Italy
Contact:

Re: Trigger setting motronic 60-2 +1home volvo b5254s 5cyl

Postby HoSDo_earth » Tue Feb 06, 2018 6:36 am

Considering that the OEM Ecu works with no trouble, it could be a matter of sensor setup in the ECU or wiring error. Are you using a custom build wiring with the PS 2000?
When you shift the gear and the needle on the tacho goes on red and scores 9000 rpm, that's bad...

User avatar
HaltechMatthew
Haltech Staff
Posts: 2452
Joined: Tue Feb 07, 2012 11:45 am
Location: Sydney, Australia
Contact:

Re: Trigger setting motronic 60-2 +1home volvo b5254s 5cyl

Postby HaltechMatthew » Tue Feb 06, 2018 2:44 pm

They should use 60-2 Reluctor with Falling edge, and Home will be Hall Effect, Pullup On, and Falling edge.

Triggering occurs at 95/455 depending on the Home edge. So I would use Trigger Angle of 65 and tooth offset of 5, and if this does not go change the tooth offset to 65 (+60 to move to the other crank phase).


Return to “Platinum Sport Series”

Who is online

Users browsing this forum: No registered users and 7 guests