P2000 2JZ-GTE VVti - Ignition Timing backwards

Questions about the Platinum Sport series ECU settings or features? Ask here.

P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby Tony the Tiger » Tue Sep 18, 2012 6:40 pm

The car is a '94 Supra RHD (JDM) with the Haltech flying lead harness and a P2000 ECU... The engine was swapped to a 2JZ-GTE VVti engine, but the wiring harness and engine wasn't installed by me, so I do not know the history of this car or how well everything has been installed.

This car had a very strange problem, and whatever value that the ignition timing is stated on the ignition map, is almost reversed... e.g. 20 deg BTDC was actually close to -20 deg instead on the timing light. It took me quite a while to figure this out because the car wouldn't run properly and the engine sounded it was under heavy ignition retard and becomes worse as I continue "advancing" the timing.

Whenever I would advance the ignition timing on my laptop, it is actually retarding it. It almost seems like it is a software glitch, so I switched laptops, re-update the firmware, re-install the software, etc... and it would do the same. I had another working P2000 unit in stock, so I swapped the unit and it would do the same thing. It's really odd...

I manage to get the car "tuned" to a driveable state with ignition values that are all skewed... My entire ignition map would be stating -20deg for all the vacuum regions, and -15 deg under boost, and the car runs like as if it was with normal timing values. Car made 415 WHP @ 16 PSI of boost on a typical 67mm turbo.

Is there something I've missed? This is the same software/laptop I've used for over dozens of Haltech tunes in the past... To re-confirm that my laptop was not glitched, I connected to another Haltech P2000 car and everything was fine. It was only this particular Supra that I am having this issue.

Any advice is greatly appreciated :)
1207 WHP ATP GTX4508R '94 Supra TT
728 WHP HKS T51R SPL '94 Camry V6
663 WHP GTX3582R Acura Integra
440 WHP GT3076R Lexus IS300
485 WHP ATP GTX3076R Lancer Evo IX
Dynamotorsports Tuning
Tony the Tiger
 
Posts: 8
Joined: Thu Nov 12, 2009 9:07 pm

Re: P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby xenocron » Wed Sep 19, 2012 1:03 am

What is the trigger setup stuff set to?
xenocron
 
Posts: 15
Joined: Wed Oct 27, 2010 5:41 am

Re: P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby Tony the Tiger » Wed Sep 19, 2012 7:39 am

Here are the settings:

Trigger Type = Motronic 36-2 + 3 Home
Trigger Angle = 46.0 deg
Tooth Offset = 5

Trigger Edge = Falling
Home Edge = Falling

Trigger Sensor Type = Reluctor
Home Sensor Type = Reluctor

Trigger Filter Level = 1 (but have tried all settings already)
Home Filter Level = 1 (but tried all settings already)

Trigger -'ve GND = No
Home -'ve GND = No


Spark Mode = Direct Fire
Spark Edge = Falling

Dwell Mode = Constant Charge
Dwell Time = 2.8 ms


Thanks :)
1207 WHP ATP GTX4508R '94 Supra TT
728 WHP HKS T51R SPL '94 Camry V6
663 WHP GTX3582R Acura Integra
440 WHP GT3076R Lexus IS300
485 WHP ATP GTX3076R Lancer Evo IX
Dynamotorsports Tuning
Tony the Tiger
 
Posts: 8
Joined: Thu Nov 12, 2009 9:07 pm

Re: P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby Tony the Tiger » Fri Sep 21, 2012 7:27 am

No suggestions from anyone here? I am tuning the car again tonight, so I will look over the car again and see if I can find the cause of the issue... Besides that. here's a copy of the file that is actually running the car right now...
1207 WHP ATP GTX4508R '94 Supra TT
728 WHP HKS T51R SPL '94 Camry V6
663 WHP GTX3582R Acura Integra
440 WHP GT3076R Lexus IS300
485 WHP ATP GTX3076R Lancer Evo IX
Dynamotorsports Tuning
Tony the Tiger
 
Posts: 8
Joined: Thu Nov 12, 2009 9:07 pm

Re: P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby Tony the Tiger » Fri Sep 21, 2012 7:33 am

I couldn't attach the file, so here's a screen cap of the timing map:
Attachments
DMTTimingMapIssue.JPG
1207 WHP ATP GTX4508R '94 Supra TT
728 WHP HKS T51R SPL '94 Camry V6
663 WHP GTX3582R Acura Integra
440 WHP GT3076R Lexus IS300
485 WHP ATP GTX3076R Lancer Evo IX
Dynamotorsports Tuning
Tony the Tiger
 
Posts: 8
Joined: Thu Nov 12, 2009 9:07 pm

Re: P2000 2JZ-GTE VVti - Ignition Timing backwards

Postby Firuku » Sat Sep 22, 2012 2:03 am

I'm sure you're aware of this, but just in case and possibly a heads up for some others:
The VVT-i 2JZ has 2 marks in the crank pulley, 60 degrees from each other. One for TDC, one for a "safe position for timing belt removal" or something. Looking at the wrong mark and adjusting your timing so might get you way off. Just a thought..
Firuku
 
Posts: 5
Joined: Fri Oct 07, 2011 10:46 am
Location: Finland


Return to Platinum Sport Series

Who is online

Users browsing this forum: No registered users and 5 guests