Launch control issue - 04 Nissan 350z Turbo

Questions about the Platinum Pro Harness 350Z and R35? Ask here.
ST350zVOLK
Posts: 2
Joined: Sat Jun 18, 2011 10:11 am

Launch control issue - 04 Nissan 350z Turbo

Postby ST350zVOLK » Tue Jun 21, 2011 1:50 pm

So I had my haltech installed 2 weeks ago and just got around to installing the Launch control,

I followed the diagrams and they are hooked up to the right wires, I have also used a normally open switch.

All the tuner did was go into AUX REV LIMIT click enable, set it to 4300rpm and set it to ignition cut.

My issue is that, the aux limiter works when driving only, and does not work when the vehicle is stopped. When the button is released I have the full RPM range.

I don't understand why it will only work when the car is in gear driving, if I put it in neutral while driving, doesn't work, push in the clutch, doesn't work and in first car stopped with clutch 3/4 down (so the clutch safety isn't depressed) doesn't workk,
its kinda like the Haltech needs to see boost pressure in order to enable it. I also tried replicating the issue on a hoist at work but the car would not build boost so it did not enable the limiter.

Is there speed values or something else that has to be set? Or am I in the completley wrong thing??? I would really like to get this working!!!

Please Help! :D
thanks

Jim

User avatar
Ignition
Posts: 1635
Joined: Thu Nov 08, 2007 10:18 pm
Location: New Plymouth, NZ
Contact:

Re: Launch control issue - 04 Nissan 350z Turbo

Postby Ignition » Tue Jun 21, 2011 9:20 pm

use a normally closed switch like a brakelight switch.

ST350zVOLK
Posts: 2
Joined: Sat Jun 18, 2011 10:11 am

Re: Launch control issue - 04 Nissan 350z Turbo

Postby ST350zVOLK » Thu Jun 23, 2011 4:11 am

The newer firmware uses the normallly open switch. I can control it to come on fine, the issue is it only seems to operate under boost


Return to “Platinum Pro Harness”

Who is online

Users browsing this forum: No registered users and 2 guests