Ecu manager 1.13 crashes

Questions about ECU Manager? Ask here.
Manuelpro
Posts: 2
Joined: Tue Mar 31, 2015 4:26 am

Ecu manager 1.13 crashes

Postby Manuelpro » Tue Mar 31, 2015 4:34 am

Hello everybody,
sorry for my poor english.
i work for a long time with ecu manager 1.11.1 since long time on my laptop (windows xp).
all is ok.
now i have bought 2 new ecu sport 1000 and for this i might upgrade ecu manager on 1.13.1
and with ecu manager 1.12.5 or 1.13.1 my laptop crash when i want open ecu manager.
i have reupgrade my laptop with ecu manager 1.11.1 and he work well.
thank you for your aid.

samkaos
Posts: 2
Joined: Tue Jan 26, 2016 9:57 am

Re: Ecu manager 1.13 crashes

Postby samkaos » Tue Jan 26, 2016 10:06 am

I just bought a Sprint 500, but I cannot use it, because ECU Manager 1.13.5 will not run on my laptop.
I click on the program, and after a delay, Windows XP says that it has crashed, before it even starts!
Very disappointed, bought an AEM and at least there software works!

Windows XP debug report:-
product_name=&name=&email=&description=&exception_type=System.MissingMethodException&exception_message=Method not found: 'Boolean System.Threading.WaitHandle.WaitOne(Int32)'.&exception_stack_trace= at com.Company.GenericLibrary.Tools.TaskProcessor.Thread`1.CreateTaskThread(LinkedList`1 tasksList, Boolean threaded)
at com.Company.GenericLibrary.Tools.TaskProcessor.Thread`1.com.Company.GenericLibrary.Tools.ITaskProcessor.AddTask(Task task)
at com.Company.GenericLibrary.Tools.TaskProcessor.Thread`1.AddTask(T task)
at com.Company.GenericLibrary.Tools.Invoker.BeginExecute(Task task, String threadId)
at com.Company.ECUManager.Core.Registration.UsageData.TryUploadBuffers()
at com.Company.ECUManager.SwfUI.MainFrame..ctor()
at com.Company.ECUManager.SwfUI.Program.Main(String[] args)&exception_type_2=&exception_message_2=&exception_stack_trace_2=&exception_type_3=&exception_message_3=&exception_stack_trace_3=&contactable=0

User avatar
Peterson
Posts: 130
Joined: Mon Aug 17, 2015 2:35 am

Re: Ecu manager 1.13 crashes

Postby Peterson » Tue Jan 26, 2016 4:05 pm

Find a laptop which has windows 7 installed and see how it goes.

JimKden
Posts: 389
Joined: Wed Jan 12, 2011 2:28 am

Re: Ecu manager 1.13 crashes

Postby JimKden » Wed Jan 27, 2016 12:21 am

I have no trouble loading with XP on two of my laptops, an old Dell and a HP.

samkaos
Posts: 2
Joined: Tue Jan 26, 2016 9:57 am

Re: Ecu manager 1.13 crashes

Postby samkaos » Wed Jan 27, 2016 10:08 am

I am not going to upgrade my operating system just to run one program. Even Altium works fine on it (and Win 7 is much slower).

I tried re-installing ECU manager, still wont work. I tuned my AEM with that laptop no problems last night, but ECU manager still won't boot up.
And people wonder why Razorbacks come with hand controllers lol

User avatar
HaltechMatthew
Haltech Staff
Posts: 2542
Joined: Tue Feb 07, 2012 11:45 am
Location: Sydney, Australia
Contact:

Re: Ecu manager 1.13 crashes

Postby HaltechMatthew » Fri Jan 29, 2016 12:56 pm

I use XP on an old Dell laptop with a serial port for Racepak duties, and it definitely runs fine.

Try running as Administrator. It looks like it is trying to access something and is being denied.

jez-h-dev
Posts: 2
Joined: Wed Feb 17, 2016 6:46 am

Re: Ecu manager 1.13 crashes

Postby jez-h-dev » Wed Feb 17, 2016 6:52 am

I get this too. Annoying. It used to at least run, but when I connected to an ECU and it downloaded the config it crashed and now won't run. No it just crashes on startup.

I've tried uninstalling it and reinstalling. Also tried removing everything from the registry to do with Haltech with no change. I've tried running it as administrator. This is on a Toughbook running Windows 7.

I've installed it on another old laptop running XP and its fine but need to get it working on my usual laptop.

Any help appreciated.

jez-h-dev
Posts: 2
Joined: Wed Feb 17, 2016 6:46 am

Re: Ecu manager 1.13 crashes

Postby jez-h-dev » Wed Feb 17, 2016 7:04 am

Found another thread on this problem.

I deleted the file user.config in C:\Users\[username]\AppData\Local\Haltech\ECUManager.exe_Url_qhzj35xt2b4l10m2lb143kpehtae5boo\1.1.13.5 and it seems to at least run now.

Will connect to car and see if it works when I get back to work tomorrow.


Return to “ECU Manager”

Who is online

Users browsing this forum: No registered users and 5 guests