Page 1 of 1

ECU Manager 1.14 not responding windows 8 laptop

Posted: Mon Dec 17, 2018 6:52 am
by RoadW3
I am using Platinum PNP for the R32 Skyline and when I installed ECU manager 1.14 without plugging in the ECU it worked fine to build my base tune but when I plugged in the USB for ECU it went to install the USB drivers and then stopped responding. Restarted the laptop and now whenever I try to open the ECU manager it immediately stated not responding and sending a report to Microsoft. Have removed and installed the software several times with the same results.

I installed ECU manger 1.13 and 1.13.5 and both work no problem but when I plug the ECU in it stated the firmware version will not work with the current software. I then installed 1.14 again and still not working with the ECU plugged in or not. The software will not open. I have tried "run as administrator" with the same results. I have even disabled virus protection with the same results.

Laptop is current and up to date with all software including Java, Direct X and Adobe.

If you have any ideas on what I need to try please let me know. It is odd it worked fine before and then wont work now.

Thanks,
Eric

Re: ECU Manager 1.14 not responding windows 8 laptop

Posted: Tue Dec 18, 2018 4:00 am
by RoadW3
So I called haltech tech support. They apparently do not know what the cause of this is. Their answer was use a different laptop. It is a software issue as it worked before but doesn’t now. They tried to say it was a windows issue but I would think if that was the case it would not have worked at all to begin with.

They advised me to check the registry for installed components but yet did not know what to check for. I asked to speak with someone who may know what to look for and was put on a brief hold and then told I needed to call Microsoft for a walk through? A walk through of what?

It’s your software but no one knows anything about it. Got it.

Re: ECU Manager 1.14 not responding windows 8 laptop

Posted: Tue Dec 18, 2018 11:51 am
by RoadW3
For future use for anyone else who has this problem and cannot find the fix here it is.

You will need to uninstall the ECU manager.
In the folder options check to see hidden folders
Go to C:\Users\(your user name)\AppData\Local and then delete anything with Haltech in the name. I just deleted the entire folder.
Next go to RegEdit or search RegEdit. On windows 8 or 10 OS just press the windows key and then "C" and it will bring up the search function. In RegEdit go to HKEY_CURRENT_USER\Software and delete the Haltech registry key.

Then your going to want to go to "my computer" and right click on the "C" drive and go to properties and then clean up files to delete any cache.

Restart the computer and then reinstall the Haltech software.

And for those wondering I did not call Microsoft as the crashing issue was obviously a Haltech software issue. Your welcome Haltech for me, an average Joe guy, figuring this out and letting others know so maybe you wont direct everyone to either get a new laptop or call Microsoft.

Have a great evening,
Eric