LS1 Coil triggering

Questions about the Elite Series ECU's? Ask here.
wb80ute
Posts: 5
Joined: Wed Jan 06, 2016 10:24 am

LS1 Coil triggering

Postby wb80ute » Fri Dec 23, 2016 7:52 pm

Hi,

just checking to see where you connect the coil ecu ground to a 2500 Elite.

The LS1 coil pins are :

D is the switched +12V
C is the ECU ignition output (1 of 8)
B is the ECU ground - which haltech connection would you recommend - Battery Ground A10 or A11, or Sensor Ground B14, B15 or B16
A is the coil ground to engine block

I am leaning towards connecting B from the coil to the Battery ground A10 or A11 on the Haltech 2500.

However if you look at the LS1 drawing, B goes to an internal ecu ground.

Just want to clear this up either way.

Regards
Glen

JimKden
Posts: 351
Joined: Wed Jan 12, 2011 2:28 am

Re: LS1 Coil triggering

Postby JimKden » Sat Dec 24, 2016 12:44 am

B connects to sensor ground.

doyle4281
Posts: 6
Joined: Thu Aug 23, 2012 1:08 pm

Re: LS1 Coil triggering

Postby doyle4281 » Fri Apr 27, 2018 10:29 pm

I too have this question about wiring ls1 coils, however on a sport 2000. The diagram just indicates 2 grounds, but it doesn’t say which ground. Chassis ground, sensor ground, or battery ground. Nothing indicates using a sensor ground, and a lot of what I’m getting from my research is people are connecting them both to chassis ground. My thought process is that the coil side ground would go to chassis and the igniter side ground would go to sensor ground. Can someone clarify this, as the instructions aren’t entirely clear on that. Thank you

JimKden
Posts: 351
Joined: Wed Jan 12, 2011 2:28 am

Re: LS1 Coil triggering

Postby JimKden » Sat Apr 28, 2018 8:01 am

I have ignitor side tied to sensor ground. Mathew lately says to tie it to the block along with the coil power ground. No issues with mine (so far). Drove 1000 miles in the last 2 days.

doyle4281
Posts: 6
Joined: Thu Aug 23, 2012 1:08 pm

Re: LS1 Coil triggering

Postby doyle4281 » Sat Apr 28, 2018 8:15 am

JimKden wrote:I have ignitor side tied to sensor ground. Mathew lately says to tie it to the block along with the coil power ground. No issues with mine (so far). Drove 1000 miles in the last 2 days.


Yeah, a little confused by this. I’m sure someone will chime in soon that will have a definitive answer.

natanel
Posts: 16
Joined: Sat Jun 12, 2010 4:58 am

Re: LS1 Coil triggering

Postby natanel » Sun Apr 29, 2018 6:55 am

Connect the negative coil to the chassis (same as the ecu ground).
Don't use the sensor ground since it's for sensors..
No gain from using the sensor ground


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 2 guests