With car off and ignition in Key On position Injector is cycling

Questions about the Elite Series ECU's? Ask here.
Mik3ymomo
Posts: 4
Joined: Tue Dec 12, 2017 11:06 am

With car off and ignition in Key On position Injector is cycling

Postby Mik3ymomo » Tue Aug 07, 2018 4:59 am

Plug and play Elite 2500 for Series 6 FD RX-7
Took a video. I know it’s the injector as I can see it in the ESP software registering 5-6 milliseconds while the car is Keyed on but Not running.
I have not begun to troubleshoot by turning off unused outputs that could be bleeding to this circuit but it does start, run and drive and have started tuning the car on short drives around neighborhood using the Haltech Series 6 base map as a starting point.
Using the factory Haltech PnP kit for the series 6. Stock FD harness.
https://youtu.be/ea9OcaT8CAI

Will start troubleshooting the problem and will update but I figured I would make this thread in case I can’t figure it out and Tech can advise what direction I should be trying to troubleshoot this.

Mik3ymomo
Posts: 4
Joined: Tue Dec 12, 2017 11:06 am

Re: With car off and ignition in Key On position Injector is cycling

Postby Mik3ymomo » Tue Aug 07, 2018 8:27 am

Another clip showing the ESP display with Injector cycling with car off and key in ON position.
https://youtu.be/f8f8sIW9W4M

User avatar
blakebonkofsky
Posts: 238
Joined: Sun Aug 02, 2015 2:58 am

Re: With car off and ignition in Key On position Injector is cycling

Postby blakebonkofsky » Tue Aug 07, 2018 9:56 am

That's not an injector pulsing. If it was an injector, it would bleed down the fuel pressure since the fuel pump isn't running. Just because ESP is showing a pulse duration for the injectors doesn't mean it's actually pulsing them. If you don't believe me, add Injector 1 Output State to your tuning page.

You need to start unplugging things until it stops. My guess is IACV or OMP, maybe even the boost control solenoid.

Mik3ymomo
Posts: 4
Joined: Tue Dec 12, 2017 11:06 am

Re: With car off and ignition in Key On position Injector is cycling

Postby Mik3ymomo » Tue Aug 07, 2018 10:36 am

blakebonkofsky wrote:That's not an injector pulsing. If it was an injector, it would bleed down the fuel pressure since the fuel pump isn't running. Just because ESP is showing a pulse duration for the injectors doesn't mean it's actually pulsing them. If you don't believe me, add Injector 1 Output State to your tuning page.

You need to start unplugging things until it stops. My guess is IACV or OMP, maybe even the boost control solenoid.

Thanks for the reply. I think I left the OMP unplugged as I am premixing. Idle air control is also removed. Boost controller is a Greddy Profec I will look into it more now that you think it’s not the Injector Cycling.

Mik3ymomo
Posts: 4
Joined: Tue Dec 12, 2017 11:06 am

Re: With car off and ignition in Key On position Injector is cycling

Postby Mik3ymomo » Tue Aug 07, 2018 11:15 am

One of my friends helping me must have plugged in the OMP. It’s junk and you called it.
https://youtu.be/0ZVr94j_2IA

User avatar
blakebonkofsky
Posts: 238
Joined: Sun Aug 02, 2015 2:58 am

Re: With car off and ignition in Key On position Injector is cycling

Postby blakebonkofsky » Tue Aug 07, 2018 3:46 pm

Mik3ymomo wrote:One of my friends helping me must have plugged in the OMP. It’s junk and you called it.
https://youtu.be/0ZVr94j_2IA


Good deal, glad it was an easy find!


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 3 guests