Surging at startup

Questions about the Elite Series ECU's? Ask here.
MavRich
Posts: 2
Joined: Sat Sep 29, 2018 12:39 pm

Surging at startup

Postby MavRich » Sat Sep 29, 2018 12:54 pm

Elite 2500 with REM. 530” Ford with F1X-12R ProCharger. 16-Injectors, Methanol. 1/8th Mile Drag car.

Main issue is that probably7 times out of 10 the car ‘Surges’ when you start it. It acts like that Roots blown car we’ve all heard. Surges from 500 or so RPM to 1400-1500 - sometimes it surges 4-5 times and the ‘settles down and isles as it should and is fine. Other times it will surge non-stop until I get aggravated and turn it off and try to start again - which rarely works. If you try to give any throttle, it Pops out the exhaust and usually dies. Other time, it will start normally, idle normally, and all is good. (Idle is set at 1400-1450ish FYI.

Another odd thing (may or may not be related) is that the car idles at 800-900 RPM when cold - seems like once it gets to 95degrees or so, it almost immediately speeds up and idles as it should (1450ish).

We have played with Transient Throttle Enrichment, Coolant Enrichment and Post Start Enrichment to no avail and have put those all back to their previous values.

Any ideas would be greatly appreciated.

Rich
3E0D2601-F54E-4112-AA3B-7EC5E13AAB12.jpeg
Fat Bottom Girl

JimKden
Posts: 389
Joined: Wed Jan 12, 2011 2:28 am

Re: Surging at startup

Postby JimKden » Sat Sep 29, 2018 11:03 pm

Are you using an idle air valve?
If so, what type is it?

MavRich
Posts: 2
Joined: Sat Sep 29, 2018 12:39 pm

Re: Surging at startup

Postby MavRich » Sat Sep 29, 2018 11:25 pm

No sir, not familiar with that. I switched from BigStuff3 this past winter.


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 4 guests