Computer recognizes ECU as a mouse.... Sort of.

Questions about the Elite Software Programmer? Ask here.
User avatar
RedLimitDom
Posts: 41
Joined: Tue Dec 09, 2014 11:56 pm

Computer recognizes ECU as a mouse.... Sort of.

Postby RedLimitDom » Wed Jun 24, 2015 10:30 am

I've intermittently had a strange problem with my tuning PC and I was curious if anyone else has had this issue.

While connected to the car, my connection will drop out, then suddenly the mouse pointer starts running all over the place I cannot click on anything or take control of the mouse pointer. I normally notice this because it starts throwing my display windows and objects in my page layouts all over the place.

I came up with my title because once I disconnect the USB the problem stops, and will come back if I re plug it in. The only fix I have found is to close and re open ESP, and or reboot the pc.

This has happened with 2 completely different PCs. Both are Asus Transformer books (different versions) running Windblows 8.1

Thoughts?
Dominick

03 Evo 8 (2.3L / 10.5:1 / Full Flex Fuel / 2500 Elite+CanExpander)

User avatar
HaltechMatthew
Haltech Staff
Posts: 2452
Joined: Tue Feb 07, 2012 11:45 am
Location: Sydney, Australia
Contact:

Re: Computer recognizes ECU as a mouse.... Sort of.

Postby HaltechMatthew » Wed Jun 24, 2015 2:44 pm

This is a driver issue not related to Haltech, but apparently if it starts happening it wont fix itself. To fix it go into the registry, backup the registry first and then edit the following value:

Location: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\sermouse
Key: Start
Value: 3

Change Value to 4, which is Disabled and it will stop this problem occurring.

A reg edit command would be as follows:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\sermouse" /V Start /T REG_DWORD /F /D 4

User avatar
RedLimitDom
Posts: 41
Joined: Tue Dec 09, 2014 11:56 pm

Re: Computer recognizes ECU as a mouse.... Sort of.

Postby RedLimitDom » Mon Jul 20, 2015 4:15 am

G'morning,

Mathew,

I went through your fix and it partially stopped my issues with the "Mouse takeover" throwing around my windows and display items. Though I have still had issues where after the connection drops out it will still freak out, but it happened 2-3 times yesterday and the PC just said it had a problem and needed to restart. The shutdown "blue screen" says search for BAD_POOL_HEADER, which is over my head in the windows debugging world.


I am also having a strange issues with the same PC and using a microphone plugged into the audio port. See the video linked below.
Summary is whenever the mic is plugged in I cannot communicate with the ECU. Seemed strange. Any thoughts?

https://youtu.be/zXaqwWAphnQ
Dominick

03 Evo 8 (2.3L / 10.5:1 / Full Flex Fuel / 2500 Elite+CanExpander)

User avatar
RedLimitDom
Posts: 41
Joined: Tue Dec 09, 2014 11:56 pm

Re: Computer recognizes ECU as a mouse.... Sort of.

Postby RedLimitDom » Wed Feb 08, 2017 3:40 am

Bump,

Is anyone else having massive amount of communication stability issues with the ecu? It won't stay connected long enough for me to download a log file nowadays.
Dominick

03 Evo 8 (2.3L / 10.5:1 / Full Flex Fuel / 2500 Elite+CanExpander)


Return to “Elite Software Programmer (ESP)”

Who is online

Users browsing this forum: No registered users and 2 guests