E8 on Z20let, Astra G piggyback

GeoffM
Posts: 3
Joined: Sat Aug 13, 2022 11:34 am

E8 on Z20let, Astra G piggyback

Postby GeoffM » Sat Aug 13, 2022 7:29 pm

Hello all, I'm new to this forum and hope I may be able to get some advice. About to install a E8 piggyback onto a 20let in a astra G. If anyone has done this I could do with some trigger info please.

Orangeblue
Posts: 158
Joined: Mon Apr 08, 2019 5:54 am
Location: Germany

Re: E8 on Z20let, Astra G piggyback

Postby Orangeblue » Sun Aug 14, 2022 4:03 am

GeoffM wrote: a 20let in a astra G. If anyone has done this I could do with some trigger info please.


X/Z20xx are 60-2 but the cam trigger is a half moon on the cam gear.
Not sure the older ECUs support that.., most likely you'd need to add a cam trigger...
Kinda like the C20XE M2.8, or CNC the cam gear to suit.

Can't tell you much about the trigger set up on the E8, i have a Elite 1500 using 104° TDC Offset Angle (balancer may have shiffted),
if you calculate it it should be around 112°-114°.., maybe someone can figure the E8 Settings out...

-Dominic
Image
'92 Opel Omega Wagon
'94 Opel Astra 'vert

GeoffM
Posts: 3
Joined: Sat Aug 13, 2022 11:34 am

Re: E8 on Z20let, Astra G piggyback

Postby GeoffM » Sun Aug 14, 2022 2:06 pm

Thanks for that, greatly appreciated. Would I be correct in saying I could run without the cam trigger but in semi sequential ignition instead? Or the ecu would need that for a home signal?

Orangeblue
Posts: 158
Joined: Mon Apr 08, 2019 5:54 am
Location: Germany

Re: E8 on Z20let, Astra G piggyback

Postby Orangeblue » Tue Aug 16, 2022 10:41 pm

You'd be correct.
Waste Spark for the ignition and seguential for the injection.
Image
'92 Opel Omega Wagon
'94 Opel Astra 'vert

GeoffM
Posts: 3
Joined: Sat Aug 13, 2022 11:34 am

Re: E8 on Z20let, Astra G piggyback

Postby GeoffM » Sat Sep 17, 2022 8:26 pm

Thank you for your information but could I possibly ask a couple more? I am having difficulty getting a clean trigger signal from the motronic setup, did you have to modify yours to get a good signal at all?

Orangeblue
Posts: 158
Joined: Mon Apr 08, 2019 5:54 am
Location: Germany

Re: E8 on Z20let, Astra G piggyback

Postby Orangeblue » Mon Oct 03, 2022 11:25 pm

GeoffM wrote:Thank you for your information but could I possibly ask a couple more? I am having difficulty getting a clean trigger signal from the motronic setup, did you have to modify yours to get a good signal at all?


No worries man, ask away.
I did in some way, the (my) stock C20NE wiring harness grounds the shielding of the trigger wires on both ends,
not sure if the Z20LETs do that, but worthchecking...
Other than that i left the base map values alone.., maybe you need to play with the filter settings.

-Domi
Image
'92 Opel Omega Wagon
'94 Opel Astra 'vert


Return to “E11v2/E8”

Who is online

Users browsing this forum: No registered users and 2 guests