E6X main fuse blowing instantly

johnnychon
Posts: 5
Joined: Sun Nov 25, 2012 3:59 pm

E6X main fuse blowing instantly

Postby johnnychon » Thu Jul 06, 2017 11:42 am

I've been in the process of installing an E6X in my 85 rx7 (FC motor). It was going pretty good. I was in the middle of cleaning up the rpm signal. I was checking my battery cable ground and when I wiggled it I could hear the haltech relays clicking, fuel pump priming etc. I tighened the loose cable went to crank the motor over again. Nothing. Lost ecu communication, no fuel pump. The 3a fuse was blown. Checked all my wiring, got my multimeter out and checked for shorts. Didn't find any. Replaced the fuse and as soon as I turned it on POP! Checked my relays and rechecked for shorts. I pulled the connector off the ecu and the fuse did not blow. Plugged it in.....pop!
Best I can figure is something internal shorting out??

User avatar
HaltechMatthew
Haltech Staff
Posts: 3304
Joined: Tue Feb 07, 2012 12:45 pm
Location: Sydney, Australia
Contact:

Re: E6X main fuse blowing instantly

Postby HaltechMatthew » Thu Jul 06, 2017 12:56 pm

Sounds like you have a bad ground in the vehicle and you used the ECU as a ground strap for your engine. Pull the cover off the ECU and see if it smells like burning!

johnnychon
Posts: 5
Joined: Sun Nov 25, 2012 3:59 pm

Re: E6X main fuse blowing instantly

Postby johnnychon » Fri Jul 07, 2017 8:08 pm

Well so far it's a blown diode.

Are there any schematics available for the e6x? Not talking the pinout, like a real electronic schematic.

User avatar
HaltechMatthew
Haltech Staff
Posts: 3304
Joined: Tue Feb 07, 2012 12:45 pm
Location: Sydney, Australia
Contact:

Re: E6X main fuse blowing instantly

Postby HaltechMatthew » Tue Jul 11, 2017 11:47 am

Not unless we want everyone to make their own.

It can be sent back for repair if you are sure you have broken it.


Return to “E6X/E6GMX/F10X”

Who is online

Users browsing this forum: No registered users and 7 guests