350Z starts up very badly with E85

Questions about the Platinum Pro Plug-in ECU's? Ask here.
JanVuo
Posts: 3
Joined: Mon Jan 07, 2019 2:04 am

350Z starts up very badly with E85

Postby JanVuo » Mon Jan 07, 2019 2:31 am

Hi

I have struggled last summer with very bad starting when climate temperature goes under 15 degrees. When it's like 20-30 degrees it may start in first or second trial but when temperature is like 10-15 degrees it may take 3-7 long starts or eats whole battery down before startup.

I have tried many things but i feel like i get it adjusted only from bad to terrible.

Car has
DW 600 cc injectors, HKS 7040 charger and everything modded for those and of course haltech pro plugin with haltech E85 sensor. Everything actually Works otherwise very well. It has professionally tuned and we got very clean curve in dyno and 420 hp/500nm out of that with 77 % ethanol.
I run whole summer with ethanol, so i dont know does it start well with gasoline but tuner said it started well with that.

I changed the cranking inj time and crank timing tables to 2D so we got the fuel composition to those. Clearly it works but it doesn't feel to help enough to get it start well. After it starts, everything works superb. Tried also to add gas to cranking and prime pulse but when i add it enough (over 50%) it starts to ignite in the exhaust but engine still not start. Added more timing to start trying to prevent that but no luck.

Also thought does it get enough air to start but how i change that in DbW

In the attachment is the map i have in car now. Do you have any possibility to check what could be wrong there.

JanVuo
Posts: 3
Joined: Mon Jan 07, 2019 2:04 am

Re: 350Z starts up very badly with E85

Postby JanVuo » Mon Jan 07, 2019 3:18 am

forgot to mention that it starts up badly only in the first startup. When it has started and engine warmed up a bit, then it starts well.

Other problem is cruise control. I can activate cruise but when i try to lock the speed it drops cruise off immediately. I use it very little so this is a minor problem but it would be nice to get it work.

s57_s2k
Posts: 9
Joined: Tue Mar 05, 2019 9:56 am

Re: 350Z starts up very badly with E85

Postby s57_s2k » Mon Mar 18, 2019 5:02 am

I am guessing your problem is in fuel automization or not enough fuel at start up.

User avatar
HaltechMatthew
Haltech Staff
Posts: 3304
Joined: Tue Feb 07, 2012 12:45 pm
Location: Sydney, Australia
Contact:

Re: 350Z starts up very badly with E85

Postby HaltechMatthew » Mon Mar 18, 2019 10:55 am

For your cruise control you should monitor the brake/clutch switch (ASCD) input. They are linked together in the factory wiring. This is the most common cause of it dropping out.

JanVuo
Posts: 3
Joined: Mon Jan 07, 2019 2:04 am

Re: 350Z starts up very badly with E85

Postby JanVuo » Tue Jun 09, 2020 12:43 am

Old Topic but if someone has the same issue, the main reason for the bad starting was faulty readings for crankshaft sensor and that was the reason it didn't ignite when engine was cold.
Haltech has faced the problem before with some other cars and they sent me a new firmware where it reads opposing edge of the cam tooth and boom, it started to respond for my crank fuel and Ignition adjustment. Now when i have done minor adjustments, it starts like it should

Very much Thanks to Haltech for the help.

Cruise Still doesn't work but i dont use it much. Brake/clutch switch gives right readings to the Haltech but it still drops it immediately when i try to set speed.


Return to “Platinum Pro Plug-in”

Who is online

Users browsing this forum: No registered users and 3 guests