R32 Platinum Pro Plug-in submerged in Townsville floods

Questions about the Platinum Pro Plug-in ECU's? Ask here.
se7enblade
Posts: 1
Joined: Sat Mar 02, 2019 12:32 am
Location: Townsville, Qld, Australia

R32 Platinum Pro Plug-in submerged in Townsville floods

Postby se7enblade » Sat Mar 02, 2019 1:54 am

Hey guys, my Platinum Pro plug-in for my r32 was completely submerged in the floods here in Townsville, as was the car but motor seems salvageable, interior not so lucky :’(
However I’ve pulled the ecu out and cleaned it up as best I can, both with 100% isopropyl alcohol and dry painters brush, ziplock bag with rice etc. so after many hours I’ve tried connecting the ecu to the pc and it recognises CP210x USB to UART Bridge Controller but ecu cannot be found in ECU Manager :( is there anything else I can try to improve my chances of getting it to work again or am I screwed? I won’t be able to replace it for a very long time due to house repairs so I’ll will take any advice at this point,
Cheers
Attachments
FD6C2622-1A67-4637-93B9-B2309F377B9C.jpeg
9F0804DD-BEE5-4809-9419-952C4EB32DB7.jpeg

User avatar
HaltechMatthew
Haltech Staff
Posts: 2912
Joined: Tue Feb 07, 2012 12:45 pm
Location: Sydney, Australia
Contact:

Re: R32 Platinum Pro Plug-in submerged in Townsville floods

Postby HaltechMatthew » Tue Mar 05, 2019 11:48 am

Pretty much when the copper in the multiple layers that these circuit board contain gets wet they are often beyond repair. You can try sending it back for us to take a look but it is Russian roulette if it is salvageable or not.


Return to “Platinum Pro Plug-in”

Who is online

Users browsing this forum: No registered users and 4 guests