VSS Speed Sensor

Questions about the Elite Series ECU's? Ask here.
lamsdon
Posts: 2
Joined: Tue Aug 03, 2021 1:34 am

VSS Speed Sensor

Postby lamsdon » Tue Aug 03, 2021 1:48 am

I am using an Elite 550, trying to read a speed sensor. The speed sensor is a "reed switch" connected to the back of the speedo, that grounds the signal. Two magnets are on the speedo cable drive.

I don't seem to be getting any sensible readings in the ESP software. It is 0 KPH when stationary but even when crawling it just goes to numbers up in the thousands, millions etc in the Data Log viewer. In the data log viewer some of these are even negative speeds! :shock: The ESP live display seems to max out at 999 KPH.

I thought I would use the manual to help me, but it doesn't seem to be correct. The only option I have is to wire it to a DPI, yet the manual states SPI. I don't have any options in the software for a pullup or selecting a VR or Hall Effect. I just have the edge rising/falling to select on.

Then there is the "Vehicle Speed Filter Scale". Can't find what this does in the manual either, seems to try and smooth the values? What do you put in there 1 to turn it on? Or is it some sort of scale?

Do I have it on the wrong pin? Should I stick an external pullup resistor? Is that to 5V or 12V? I guess a reed switch may have a little bounce on the signal..will that be an issue?

lamsdon
Posts: 2
Joined: Tue Aug 03, 2021 1:34 am

Re: VSS Speed Sensor

Postby lamsdon » Tue Aug 03, 2021 7:26 pm

Perhaps I've missed a product manual somewhere, but found some details hidden on the wiring diagram. Says there is a 5V pullup already.

I checked the signal and on the negative closing edge it bounces for ~250us. Rising edge is better, but still one or two spikes.

I will add a 47R + 10nF Snubber across the contacts and switch to the rising edge....or is there a way to debounce it in the ESP software?


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 8 guests