LS3 Elite harness and alternator wiring.

Questions about the Elite Series ECU's? Ask here.
boXXer
Posts: 9
Joined: Thu Sep 03, 2020 9:48 am

LS3 Elite harness and alternator wiring.

Postby boXXer » Tue Mar 09, 2021 2:19 am

Hi guys. I have the early CTS-V style alternator ( 25766345) on my LS3 and haltech elite 2500. The loom supplied by them has a 12v switched live on the alternator plug. I am getting around 13.3 volts when running. Should the plug have 5v going to the ‘L’ terminal, not 12v. I also have nothing on terminal ‘F’. I read that it can burn out the regulator? Do I need to add a resistor or is there one already inline? I have attached a pic of my alternator.
Attachments
0E0357D2-710B-4960-8955-7EB67F66E062.jpeg
0E0357D2-710B-4960-8955-7EB67F66E062.jpeg (20.53 KiB) Viewed 245 times
4B9F2B8A-9B4A-4156-BFF5-6F3ACA3DF84B.png

boXXer
Posts: 9
Joined: Thu Sep 03, 2020 9:48 am

Re: LS3 Elite harness and alternator wiring.

Postby boXXer » Tue Mar 09, 2021 7:41 am

Been reading for the last couple of hours. Still can’t work it out. I wish the manual would state what wires to use for what alternator. I found this from an elite 950 manual, I’m not sure if this is the same for the 2500 but it doesn’t mention CTS alternators and I’m trying to work out what is closest.

I also measured voltages and took videos of the 2 ALT wires. Solid red is a stable 12.3 volts, but the grey/red trace is 12.6 and is always moving around. This is just with ignition switched on, not running. Both are dead when ignition off. I’ve attached pics
Attachments
7DABF6AB-D980-4F1E-B37A-1FD265AE31A7.jpeg
5003EF4C-4B98-4171-9CAF-FD5EFF1DCCC7.jpeg
47C4181B-489A-4D00-8D1B-729F1DB469DA.jpeg


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 5 guests