Page 1 of 1

PLEASE Help checking my setup and basic settings.

Posted: Sat Nov 27, 2021 7:45 pm
by Smithy688
Hi, I have a Aircooled VW Beetle EFI turbo motor I have built it's a 2276cc with an elite 550.
It runs on the engine stand and starts no issue but is running really rich and I have no to little experience with tuning as I usually build carby engines
Any help tuning or setting up would be greatly appreciated.
I’m running an AEM connected to the Haltech for AFR info. Thanks heaps I know it’s a bit different, engine wise.
I need it running well enough to burn in the flat tappet cam at 2000rpm for 20mins.
Then it’s going in the car and to a Dyno to be tuned.
Thanks heaps everyone.

MAP attached below,

https://drive.google.com/file/d/1ZKUTN5 ... sp=sharing

Here is a video of it running on the engine stand,

https://drive.google.com/file/d/1hCaq0t ... sp=sharing

Re: Help tuning or checking my setup

Posted: Sun Nov 28, 2021 2:02 am
by JimKden
If you set it for O2 closed loop control it will correct to the AFR that is in the Lambda Target Table and store the correction in the long term correction table. From time to time apply the long term table to the base table. There are Youtube videos on the Haltech channel explaining the process.

Re: Help tuning or checking my setup

Posted: Sun Nov 28, 2021 10:28 am
by Smithy688
Yes its already in closed loop, so still unsure why its running so rich. I really need someone to look through my map (not tune it) but just check my settings are ok.
Is there anyone on here that can do that?
Many thanks Mark.

This is a list of the system.
Haltech Elite 550 ECU and premium harness.
Bosch injector 627CC @ 3BAR 3/4 heights EV14 E85 compatible Extended nose X 4.
044 Bosch inline fuel pump.
Turbosmart FPR800 fuel pressure regulator set to 40 psi.
Dubshop crank trigger 36 teeth 1 missing.
Internal map sensor in Haltech ECU.
Oil temperature sensor.
Air temperature sensor.
Haltech 3port boost valve.
Turbo smart external waste gate 7psi springs.
G25-550 Pulsar turbo with oil restrictor and turbo smart oil pressure regulator.
Bosch 2x2 coil with ignitor running as wasted spark system.
EFI billet 50mm throttle block with seals for boost.
Delco TPS.

Re: PLEASE Help checking my setup and basic settings.

Posted: Mon Nov 29, 2021 3:18 am
by JimKden
I took a look. No comments on anything associated with boost, I have no experience there.
1. The most glaring isse is the Injection Systems Stage 1 Flow, the value input is 240cc/min, whereas you list Bosch injector 627CC @ 3BAR as the size. Correct that and get the dead times for those injectors and check the that impedance setting is correct, now at High.

ESP is now squirting a pulse width for a 240cc/min injector where a much smaller pulse would be with the larger injectors.

2. In the Main Setup, Engine Fuel tab, try semi-sequential instead of batch.

Hope this helps.

Re: PLEASE Help checking my setup and basic settings.

Posted: Mon Nov 29, 2021 9:52 am
by Smithy688
JimKden, thank you so much, I'm now getting this thing running correctly , your help has been so awesome and I thank you very much for taking the time to look at my map,
So many little things to set that I had no idea about.