Elite 2500 DBW issues

Questions about the Elite Series ECU's? Ask here.
E82_3v
Posts: 2
Joined: Tue Nov 30, 2021 2:36 pm

Elite 2500 DBW issues

Postby E82_3v » Tue Nov 30, 2021 3:07 pm

I am having a issue with the dbw configuration on elite 2500. I have it setup on a 4.6 3v ford mod motor and I am able to configure throttle pedal and see app1&2 voltages swing properly and opposing like they should. However even though I can see tps 1&2 voltages reading and swinging properly the dbw fails to even try to move in the calibration - never makes it past the first step. Triple checked all wiring , used a premium universal harness and wires were all one piece initially before getting into diagnostics. I even grabbed a m54 throttle body and wired a pigtail up and same thing. I get good tps voltages but no dbw movement or even a sound of trying when trying to calibrate. Spent a whole day on phone with tech support they are out of ideas , tuner who I always work with is out of ideas, I’m stumped at this time - I do have the ign and the inj fuse pulled currently and the instructions said to do that during configuration . Not sure if either of those circuits having their fuse out would affect ?

User avatar
blakebonkofsky
Posts: 386
Joined: Sun Aug 02, 2015 2:58 am

Re: Elite 2500 DBW issues

Postby blakebonkofsky » Wed Dec 01, 2021 1:26 pm

E82_3v wrote:I am having a issue with the dbw configuration on elite 2500. I have it setup on a 4.6 3v ford mod motor and I am able to configure throttle pedal and see app1&2 voltages swing properly and opposing like they should. However even though I can see tps 1&2 voltages reading and swinging properly the dbw fails to even try to move in the calibration - never makes it past the first step. Triple checked all wiring , used a premium universal harness and wires were all one piece initially before getting into diagnostics. I even grabbed a m54 throttle body and wired a pigtail up and same thing. I get good tps voltages but no dbw movement or even a sound of trying when trying to calibrate. Spent a whole day on phone with tech support they are out of ideas , tuner who I always work with is out of ideas, I’m stumped at this time - I do have the ign and the inj fuse pulled currently and the instructions said to do that during configuration . Not sure if either of those circuits having their fuse out would affect ?


You need the injection fuse in place, as pin A26 (injector return current) also powers the DBW circuits. Reinstall that fuse and try again.


Return to “Elite Series”

Who is online

Users browsing this forum: No registered users and 6 guests