Oil pressure sensor calibration issues (Defi)

Questions about the Elite Software Programmer? Ask here.
Ricebox
Posts: 8
Joined: Tue Feb 05, 2019 12:31 pm

Oil pressure sensor calibration issues (Defi)

Postby Ricebox » Tue Feb 05, 2019 1:12 pm

Hey guys, i am running a Defi oil pressure sensor with my elite 1500, i got the sensor hooked up and am seeing 142 PSI with the ECU/ignition on (no oil pressure). from what i have gathered online the sensor is .5v to 4.5v 10 bar(145psi) max. i entered this information in the calibration table and am still getting this false reading. there were three wires; red - power, black - ground, white - signal and i wired those to the elite accordingly.

any ideas on what the issue could be?

Thanks

User avatar
HaltechMatthew
Haltech Staff
Posts: 3304
Joined: Tue Feb 07, 2012 12:45 pm
Location: Sydney, Australia
Contact:

Re: Oil pressure sensor calibration issues (Defi)

Postby HaltechMatthew » Tue Feb 05, 2019 3:01 pm

Turn the pullup off.

Ricebox
Posts: 8
Joined: Tue Feb 05, 2019 12:31 pm

Re: Oil pressure sensor calibration issues (Defi)

Postby Ricebox » Wed Feb 06, 2019 2:38 pm

That seems to have done the trick, thanks!. reading 2-3 psi on ignition-on but i assume that is normal.

Rallly1
Posts: 16
Joined: Sun Nov 10, 2019 8:10 am

Re: Oil pressure sensor calibration issues (Defi)

Postby Rallly1 » Wed May 06, 2020 9:19 am

Ricebox wrote:Hey guys, i am running a Defi oil pressure sensor with my elite 1500, i got the sensor hooked up and am seeing 142 PSI with the ECU/ignition on (no oil pressure). from what i have gathered online the sensor is .5v to 4.5v 10 bar(145psi) max. i entered this information in the calibration table and am still getting this false reading. there were three wires; red - power, black - ground, white - signal and i wired those to the elite accordingly.

any ideas on what the issue could be?

Thanks




Can you tell me how you sent signal from defi gauges to elite ecu?


Return to “Elite Software Programmer (ESP)”

Who is online

Users browsing this forum: No registered users and 2 guests