Haltech knock sensor signal looks wrong in datalog - anyone know what the sample rate the ecu uses is?

Questions about the Elite Software Programmer? Ask here.
cbDrift
Posts: 17
Joined: Tue May 26, 2020 7:21 am

Haltech knock sensor signal looks wrong in datalog - anyone know what the sample rate the ecu uses is?

Postby cbDrift » Sun Apr 18, 2021 9:50 am

knock signal.jpg

knock signal 2.jpg


Heya - does this look correct for a log of the knock sensor signal at 100hz from the internal datalogger on an e2500 ecu?

Or does it look like a faulty sensor?

its given a stepped log since i installed it from day 1 and from youtube vids it sorta looks like i should get a much more granular and detailed signal not these "stepped" signals that i do get...

Quite happy to replace a damaged sensor if that's what people think it is.

cbDrift
Posts: 17
Joined: Tue May 26, 2020 7:21 am

Re: Haltech knock sensor signal looks wrong in datalog - anyone know what the sample rate the ecu uses is?

Postby cbDrift » Tue Apr 27, 2021 4:05 pm

Checked with the Haltech phone support and got this back
"
After checking with our firmware engineers, what you are seeing in the knock signal data is correct.
The ECU will ‘hold’ the last peak recorded knock signal value for a period of 500ms in order to make logging and analysis of this channel easier. At this time, the raw knock signal value isn’t brought through to the front-end for logging, however I have requested that this be added in a future firmware for better analysis of the knock signal.
"


Return to “Elite Software Programmer (ESP)”

Who is online

Users browsing this forum: No registered users and 1 guest