iC7 Dash Boot Loop Help!

Questions about the IC-7 Dash? Ask here.
CRVTEC
Posts: 1
Joined: Sun Jun 07, 2020 11:01 pm

iC7 Dash Boot Loop Help!

Postby CRVTEC » Wed Dec 30, 2020 4:00 pm

Hi everyone,

I hope I can find some answers on here from the Haltech Gods. I tried updating my iC7 dash tonight using the ICC software to v1.5.2. The update never finished; on the bottom left of the ICC software, it kept saying "updating." It restarted itself and kept on boot-looping; I left the dash connected to my computer for about a half-hour to see if it would sort itself out but no luck. I shut it all down, and now my dash is stuck in a boot-loop. Any help would be much appreciated.

Cornick763
Posts: 2
Joined: Sat Jan 09, 2021 10:35 am

Re: iC7 Dash Boot Loop Help!

Postby Cornick763 » Sat Jan 09, 2021 10:43 am

Mine did the exact same thing mate i ended up downloading the icc software on a newer laptop and updated all the drivers on it (only cause i turned my old laptop into a zigsaw puzzel on the ground :) ) Then i opened the default haltech gauge set up and and plugged the dash in as soon as it indicated dash connected i sent the gauge setup to the dash and it worked for me, have to be quick tho cause the dash keeps dropping out of connection in the loop. Then i updated it once i got it sorted. Hope this helps i winged it and it worked for me.

82ProchargedCapri
Posts: 1
Joined: Wed May 11, 2022 10:41 pm

Re: iC7 Dash Boot Loop Help!

Postby 82ProchargedCapri » Wed May 11, 2022 10:45 pm

Mine literally did the exact same thing yesterday while trying to update firmware. Cant seem to recover it. Idk what to do its brand new!

cstone94
Posts: 3
Joined: Sat May 14, 2022 12:28 am

Re: iC7 Dash Boot Loop Help!

Postby cstone94 » Sat May 14, 2022 12:32 am

I had the same issue last night. Updated firmware and the dash and updater froze. Luckily it self recovered and then I restarted the update and it worked. However, I can no longer talk to the dash. Plugging directly into the Elite 1500, I can talk to it. If I plug into the IC7, windows does not acknowledge the dash anymore. I've tried 2 laptops and same issue.


Return to “iC-7 Dash”

Who is online

Users browsing this forum: No registered users and 2 guests