NEXUS Problems

Questions about the Nexus Series ECU's? Ask here.
Topfun99
Posts: 127
Joined: Tue Mar 11, 2008 12:36 am

NEXUS Problems

Postby Topfun99 » Wed Dec 16, 2020 10:20 pm

Be aware that while using the hard line USB communication cable many strange things can happen. One in particular has happened to me several time before I realized have the cable connected was causing the problem. While making a pass with the comm cable hooked up, just past the 1/8 mile point the car would abruptly lose power and if it were shut down. Engine never stopped but afterwards the ECU was showing so many DTC codes that I stopped counting them. The datalog from that pass would capture this interruption and data associated with the 5v system would abruptly and drastically change. Once you turn the key on/off (or reboot), it appears to return to "normal" again and the DTCs go away. BUT - going thru various settings in the program will show the ECU has changed several of them that have to be changed back.

The changes I've found usually are related to RPM limiter settings and items being data-logged. The last time it happened the "glitch" appears to have corrupted the file so badly the car wouldn't start. The pulse duration for the primary injectors was "stuck" at approximately .7ms and nothing in the software would change that. I finally completely imported an older map and it started responding normally again.

I'm also suspecting that the comm cable may be causing the ECU to start a new datalog of approximately 3 seconds duration every time I turn the key on/off while hooked up to the ECU.

I would use the WIFI connection exclusively but when you turn the key off (even briefly) it interrupts and it takes 10-15 seconds to fine the WIFI again or I have to go to my WIFI settings and click on the ECU connection to make it reconnect even though it's set for automatic. Also, because I have over 1000 datalogs that can't be deleted, it becomes very slow downloading a current datalog because it's send data to populate the complete datalog list. Using the USB cable works better for those reasons but now I know to try and keep the cable disconnected when making a pass.

This is not my first Haltech ECU. Over the last 13 years I've used the E11V-2, Platinum Sport, Elite (with REM add-on) and now the NEXUS. With the other ECUs the laptop was in the seat next to me and hooked up to the ECU while either making a pass or driving down the road almost 100% of the time and never had so many problems.

Hopefully these problems can be fixed in future firmware updates.

HaltechMatt
Haltech Staff
Posts: 131
Joined: Tue Sep 25, 2007 6:39 am

Re: NEXUS Problems

Postby HaltechMatt » Fri Dec 18, 2020 10:12 am

Thanks for the feedback on this, its certainly a concerning set of circumstances that you have having with the USB cable connected. This is the first report we have received about this issue, however we are already working on updating the USB communications to fix other potential issues.
The detailed description you have given here is really helpful and the engineering guys are looking at what could be happening on your VCU and if it relates to the fixed they are working on.
What would be helpful would be if you could email us a copy of your map (just email me directly and i'll pass it on to the software guys - [email protected]), that'll just help us speed up the process of narrowing down why you are seeing this.
Once we get the map and have some solid answers I'll post more information.

Topfun99
Posts: 127
Joined: Tue Mar 11, 2008 12:36 am

Re: NEXUS Problems

Postby Topfun99 » Fri Dec 18, 2020 11:29 pm

Email sent to you Matt.


Return to “Nexus”

Who is online

Users browsing this forum: No registered users and 1 guest