Nexus Issues

Questions about the Nexus Series ECU's? Ask here.
TurboTerry87gn
Posts: 18
Joined: Fri Aug 14, 2015 1:54 am

Nexus Issues

Postby TurboTerry87gn » Sun Apr 18, 2021 3:01 pm

Nexus Issues

Nexus ECU, Haltech Dash, I/O Expander 12, Can bus Keypad 15.

Went to tune my car on the dyno today and I had a lot of issues.
On Wi-Fi if you try to make changes too fast the software crashes. It crashed about 30 times today.
For example, if you’re working the VE table and try to linearize too quickly it will crash.

I checked for software updates (Current 1.0.14.1), although my firmware in the VCU was not current, I believe I was on 1.04.0 but now I upgraded to 1.06.0
These problems happed after the firmware update. I had the car running in the driveway for weeks and ran several times before this update with no issues as described below.

After the Firmware update I started getting DTC P195C, (Current): PDM Hardware error – UVLO Flagged.
Also sometimes the ECU would not power down. The ECU PDM powers the Dash from HCO1 and the screen stays on with the ignition key off the ECU lights are still on. If I kill the power with the main disconnect switch then it will work again.With the ECU stuck ON,if I press the keypad to start the engine (Starter Relay with coil switched to ground from ign#9 and positive side from DPM HCO-3) with the key off and ECU stuck on, it immediately kills the ECU and the dash and ECU power down.
The same thing happens (Kills the ECU when Stuck on) with the keypad button that over rides the fuel pump relay to turn it on, but that relay is switched to ground from the expander box and its coil is powered from HCO1.) The expander box is powered from HCO1 also and is grounded at the same exact main star ground point as the Nexus.
So troubleshooting this “ECU stuck ON” issue, what is happening is HCO1 supplies power to the fuel pump relay coil and the engine start coil. If I unplug both relay coils the issue goes away. I would suggest its back feeding into the Nexus digitally switched to ground output and up thought a pull up resistor into the VCC but this doesn’t hold true because the fuel pump relay is switched from the I/O expander 12. So not sure I’m yet. Later Today, I also found when its stuck on if I go on Wi-Fi and “reboot the VCU through the software it powers down, so nothing is back feeding.
So I have an on board air pump that is controlled from a key pad button and after the update, the keypad would not latch in and turned into an intermittent key button, the FW update lost one of my generic conditions that allows me to designate how I want to control one of my keypad push buttons, either latched or intermittent.

TurboTerry87gn
Posts: 18
Joined: Fri Aug 14, 2015 1:54 am

Re: Nexus Issues

Postby TurboTerry87gn » Mon Apr 19, 2021 12:39 am

So this morning I decided to pull the ECU from the car and do some bench testing by powering up the VCU though the USB cable to test the crashing issue.
On FW version 1.06 if I linearize the VE map too quickly the software crashes.
I did this several times.
Also the 3 dimensional map starts getting black areas like the application is having issues while making VE changes too fast.

I reverted to FW 1.04 and the is issue went away completely and I can tune just as fast as I can on an Elite ecu.

I went to FW version 1.05 and the crashing started again, so this is where the problem started.

Back to 1.06 crashing still.

Back to 1.04 again and everything is great again.

Orangeblue
Posts: 120
Joined: Mon Apr 08, 2019 5:54 am
Location: Germany

Re: Nexus Issues

Postby Orangeblue » Sat Apr 24, 2021 7:54 pm

Have you called/emailed tech support?

Maybe there is a hotfix...
Or just to report the bug

-Domi
Image
'92 Opel Omega Wagon
'94 Opel Astra 'vert


Return to “Nexus”

Who is online

Users browsing this forum: No registered users and 1 guest